Product Overview
Flexisip is a complete, modular, and scalable SIP server that offers an easy-to-install solution for deploying your own SIP service. This out-of-the-box solution provides all the features required to run a SIP VoIP service, with a focus on interconnecting with Apple's and Google's push notification systems. Flexisip can be deployed in various scenarios, including cloud, embedded, and as a push gateway, making it an ideal choice for organizations looking to integrate SIP services into their existing infrastructure.
Main Features
Flexisip offers the following main features:
PROXY
- Transport protocols: SIP/UDP, SIP/TCP, and SIP/TLS
- Digest and TLS client certificate authentication
- Routing based on a registrar database or static route file, with forking
- Interconnected with push notifications systems for reliably notifying mobile apps of incoming calls or messages (including support for RFC8599 for the transmission of push notification information through REGISTER requests)
- "Store and forward" logic for SIP MESSAGE (IM) to deliver text messages when the recipient connects to the network
- NAT-aware with a built-in media relay module and ICE/STUN support for high-level event logging for activity monitoring
- Real-time statistics available through a command-line interface
- High availability and cluster mode for large deployments
- ExternalAuthentication, a proxy module that performs SIP request authentication based on the inputs of an external HTTP service
PRESENCE
- Manages SIP SUBSCRIBE and PUBLISH from client applications to:
- Identify users of the service within the address book
- Provide users with real-time presence status
- Offers a "Server known resource lists" feature that allows directly provisioning a Liblinphone-based client with a server-defined contact list, together with associated presence information
CONFERENCE (for group messaging and group calling)
- Entirely SIP-based solution
- Efficient management of groups and participants
- Multi-device support
- Notifications of group events (users joining or leaving, new admins, etc.)
- Can be integrated into an existing third-party server for more details, see our wiki
Implemented Standards
Flexisip supports the following standards:
- SIP, RFC 3261
- An Extension to the Session Initiation Protocol (SIP), RFC 3581 (use of rport parameter)
- A Session Initiation Protocol (SIP) Event Package for Registrations, RFC 3680
- Extension Header Field for Registering Non-Adjacent Contacts, RFC3327
- Managing Client-Initiated Connections in the Session Initiation Protocol (+sip.instance parameter), RFC 5626
- Connection reuse in the Session Initiation Protocol (alias parameter), RFC 5923
- GRUUs; RFC 5627
- Push Notification with the Session Initiation Protocol (SIP), RFC 8599