Stalwart JMAP: A Secure, Fast, and Scalable Email Server
Stalwart JMAP is an open-source JSON Meta Application Protocol (JMAP) server designed to be secure, fast, robust, and scalable. As a modern protocol for synchronizing data such as mail, calendars, or contacts, JMAP makes much more efficient use of network resources.
Main Features:
Security and Robustness:
- Encryption at rest with S/IMIME or OpenPGP
- Built-in Spam and Phishing filter
- OAuth 2.0 authorization code and device authorization flows
- Access Control Lists (ACLs)
- Rate limiting
Scalability and Flexibility:
- Pluggable storage backends with support for RocksDB, FoundationDB, PostgreSQL, MySQL, SQLite, S3- Compatible, Redis, and ElasticSearch
- Internal, LDAP, and SQL database authentication
- Built-in SMTP server for local delivery and JMAP Email Submissions
- Full-text search available in 17 languages
- Disk quotas
- Sieve scripting language with support for all registered extensions
- Email aliases, mailing lists, subaddressing, and catch-all addresses support
Compliance:
- JMAP Core (RFC 8620)
- JMAP Mail (RFC 8621)
- JMAP over WebSocket (RFC 8887)
- JMAP for Sieve Scripts (DRAFT-SIEVE-13)
Stalwart JMAP is designed to be a reliable and secure email server that can handle large volumes of users while providing advanced features and compliance with industry standards.